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Abstract 

A soft-board application allows users to write, draw, and manipulate graphics just 
like they would do with physical aids such as chalk/white boards or pen and paper. 
These applications have over the years advanced from basic shapes and colouring to 
merged shapes, rotating shapes, patterns, and web themes. At the same time, existing 
tools on soft-board applications are limited to texts, selections, arrows, pencil, 
connectors, basic shapes, stars, and flowcharts, hence less appropriate for teaching 
and learning. This paper investigates tools needed in teaching and learning and 
develops an extended soft-board application with most tools for physical and 
biological sciences. A comparative analysis with related applications is made, scoring 
our application highest on easy of use, learnability, and usability features of effective 
user interface design. 

Introduction 

A Soft-board application is a software application that can be used by learners, 
teachers, and facilitators, among others, to perform activities such as illustrations, 
drawings or other writings just like they would do on a chalk/white board, or using 
pen/pencil and paper. The application can be used as a teaching/learning aid instead of 
physical teaching/learning aids such as chalk/white board, charts, to mention and 
allows work to be saved for future reference. 

This application ultimately provides all those and even many more utilities 
(functionalities) that a teacher/learner needs in an educational well-being especially in 
this era where education is diverting away from hard-materials such as text books and 
chalk boards in preference to soft-materials such as e-learning tools and soft board 
application. 

Critique of the Related Applications 

Despite of the growing number of Computer applications in education, little emphasis 
has been given to applications that can enable teachers and learners develop sketches 
as well as illustrations (diagrams/drawings) in a specific and local context. As a result, 
tools provided by the existing softboard applications are not optimised for Ugandan 
educational needs. Consequently, the need to extend such applications is eminent to 
facilitate production of good teaching content and hence learning. 
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 The UGADraw System 

The UGADraw System Features 

The UGADraw system provides an environment where the teachers/instructors and 
learners can illustrate diagrams or drawings, write freehand, perform paint operations 
(in a local context) and perform chart/graph operations, among others. Therefore, it 
provides an environment equivalent to a chalk or whiteboard. The features of 
UGADraw system include: 

� The software can be installed on a Windows Operating System environment 
and used offline. 

� Provision for the user (teacher, instructor or learner) to write free hand. 
� Provision to perform extended paint operations (including local contexts). 
� Perform chart and other drawing operations. 

The UGADraw System Model 

UGADraw is a non-distributed system that is used offline. It constitutes individualised 
(group) self-paced e-learning where an individual or a group of individuals (such as in 
a classroom environment) use the system offline (maybe, with the aid of other 
hardware such as a projector). 

The UGADraw Tools  

UGADraw – PicEditor 

This component provides the user with the ability to perform extended paint 
operations. Figure 1 shows the screenshot of UGADraw – PicEditor on start up. 

 

Figure 1: Screenshot of UGADraw - PicEditor 
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This PicEditor provides the user with the ability to edit, design and manipulate 
pictures that may be used for teaching purposes, or may used in conjunction with 
other applications for example, Microsoft PowerPoint for presentations. The features 
are mainly tailored towards meeting Ugandan educational needs. 

The title bar contains the name of the main application and the name of the sub-
application (when maximised). It also contains buttons for minimising, maximising 
(or restoring) and closing the main application. 

The menu bar contains the following menus: File, Edit, View, Format, Graphics, Tool 
and Help. The File menu contains items such as; New, Open, Save, Save As, Print and 
Recent Files.  The Edit menu contains the following items; Undo, Redo, Cut, Copy, 
Paste, and Delete. The Format menu items include Font, Draw Styles, Fill Styles, 
Background Colour, Foreground Colour and the Fill Colour. Meanwhile the Graphics 
menu contains graphics manipulating items such as Rotations and Colour Filtering. 
Whereas, the View menu provides options for visualizing Toolbars, Status bar, and 
Zoom. The Tools and Help menus contain the other sub-applications (SoftBoard, 
ChartEditor and Drawing Tool) and Help Tips and About respectively. 

When this sub-application is maximised, the menu bar also accommodates the buttons 
for minimising, restoring, and closing this sub-application. Otherwise, these buttons 
are located on the sub-application’s title bar including the name of this sub-
application when restored (not maximised). 

It has a standard toolbar that contains the short-cuts to some of the most commonly 
used items on the menus. This toolbar also contains some additional tools that may 
not be there in the menus such as Text, Labels, Eraser, Pencil, Select-Drag-and-Drop, 
Shapes (both regular and irregular), as well as graphics manipulating tools such as 
Brushes, and Fill. Besides, buttons are also included for easy access to UGADraw’s 
ChartEditor, Abacus Math, Teaching Clock and Maps. 

Meanwhile, the formatting toolbar provides easy access for changing font attributes. It 
also provides a Slider used to change the size of drawings, brushes and pencil. 

It has a sidebar that gives the user the ability to easily such for graphics files in the 
computer’s drives for editing or viewing. The sidebar also provides options for 
colours including standard colours and mixed (or already customised) colours.  

It has an adjustable interface for editing the pictures. The contents of this editing 
surface can thereafter, be saved or printed. 

The status bar, when activated gives the file being worked on and the position of the 
mouse pointer relative to the editing interface. 

Figure 2 (below) shows the demonstration or illustration of one tool that is, maps as 
used as visual aid in a classroom environment. 
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Figure 2: UGADraw – PicEditor illustrating map of A frica 

UGADraw – SoftBoard 

This feature allows the user such as a teacher to perform illustrations, free hand 
writing among others in a conventional classroom setting. It can be used as a visual 
aid instead of a chalk/whiteboard with the aid of an electronic projector. The free 
hand writing can be done by using MousePen as the pointing device instead of the 
standard mouse since it allows free hand writing more naturally than the standard 
mouse. This allows the teacher or the instructor to write in any language instead of the 
keyboard text that restricts the user to keying only alphabets or symbols available on 
the keyboard. Whereas with the help of suitable pointing device (such as MousePen), 
the user can perform illustrations such as deriving equations, drawing sketches or 
writing symbols in any language free hand. Figure 3 shows the screenshot of 
UGADraw – SoftBoard. 



5 
 

 

Figure 3: Screenshot of UGADraw – SoftBoard 

 This is the interface for the SoftBoard that provides the user with various tools for 
illustrations and text (both keyboard text and handwritten text) for instructional and/or 
teaching purposes. 

It has a title bar that (when maximised), contains the name of the main application 
(that is, UGADraw), the name of the file being worked on (which assigns it a default 
name ‘Untitled SoftBoard’ for an unnamed file) and the name of the sub-application 
processing that file (that is, SoftBoard). This title bar also contains minimise, 
maximise (or restore) and close buttons for minimising, maximising (restoring) and 
closing the whole (main) application. But when minimised or restored, the file name 
and the sub-application named are transferred to the sub-application window title bar. 

It also has a menu bar that contains the following menu items; File, Edit, View, 
Format, Window, Drawing, Tools and Help. The File menu contains items such as 
New, Open, Save, Save As, Print and Recent file list for file operations. The Edit 
menu contains functions for editing the file such as Undo, Redo, Cut, Copy, Paste, 
Select All and Print Screen (for capturing the screen contents). The View menu has 
the items for changing the visibility of some tools such as the Tool bars, Status bar as 
well as the Rulers (vertical and horizontal).  

The Format menu has items such as Text, Board Colour, Text or Writing Colour and 
Drawing Colour for formatting (changing) the appearance (colour) of the board, text 
and drawings as well as formatting text settings. The Window menu contains Zoom 
item for changing the size of the board. It also contains the list of other open 
windows. The Drawing menu contains items such as Drawing Tool (that enables the 
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user to quickly access the window for drawing/diagram operations), Shape Styles, 
Line Styles and Fill Styles for customising the shapes, lines and filling of the shapes 
respectively. The Tools menu has list of sub-applications that are available with this 
application. These items act as short-cuts to those sub-applications such as PicEditor, 
ChartEditor and Drawing Tool. The Help menu items contain Help Tips and About. 

The menu bar also contains the buttons for minimising, restoring and closing this sub-
application when the sub-application is maximised. Those minimise, maximise and 
close buttons are transferred to the sub-application window when minimised or 
restored. 

This interface also has a standard toolbar that contains icons for ease of use and 
accessibility of some of the most common file operations in the menus such as New, 
Open, Save, and Print, Cut, Copy, Paste, Undo, Redo and Selection. The standard 
toolbar also contains buttons for various tools such as Pencil, Text, Label, Zoom, 
major Shapes, Eraser, Clear and the Handwriting tool (that requires MousePen i608 as 
the pointing device instead of the standard mouse). Also, the icons for PicEditor and 
ChartEditor are included for easy access to those programs. Additionally, calendar 
(monthly) and a digital clock are also shown in the standard toolbar.  

It also has a formatting toolbar that contains options for changing font attributes such 
as the name, size, text colour, and regular, bold, italic and underlined text. The 
formatting toolbar also contains a slider that is used to adjust the size of handwritten 
text, drawings and pencil. 

It has a board that is used as the interface performing all the writings, drawings, 
illustrations and text. 

The status bar contains the progress bar, the file name, position of the mouse pointer 
on the board, the size of the board, the system time and date. The status bar also gives 
the name of the active tool being used.  

It provides the user with the ability to save and/or print the contents of the board, open 
a new board as well as open existing files in the computer’s drives that can be 
supported by this SoftBoard. 

Figure 4 (below) shows the demonstration of UGADraw – SoftBoard to perform 
illustrations (using standard mouse as the pointing device but not the 
required/appropriate pointing device). 
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Figure 4: UGADraw – SoftBoard performing illustrati ons 

UGADraw – ChartEditor  

The UGADraw – ChartEditor provides a customisable interface that allows the user to 
form graphs or charts of different types. It has data sheet that is used for entering the 
data to be graphed. The Figure 5 (below) shows the screenshot of the demonstration 
of the UGADraw – ChartEditor to plot graphs and Charts of different flavours. 
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Figure 5: Screenshot of UGADraw - ChartEditor 

This UGADraw – ChartEditor has a title bar that contains the main and sub-
application name (when maximised), minimise, restore and close buttons for the main 
application. 

The menu bar contains various menus for the chart including Edit, View, Insert, 
Format, Tools, Data, Chart and Help. When the sub-application is maximised, the 
menu bar also accommodates minimise, restore and close buttons for the sub-
application. 

The standard toolbar contains various options for the editing the chart such as cutting, 
copying, importing files, chart types, grids, axes, to mention that provide ease of use 
of the sub-application.  

Whereas, the formatting toolbar contains options for formatting text to be put in the 
chart (or graph) and the text and/or figures in the datasheet. 

This UGADraw – ChartEditor interface can be modified for other chart types and 
Diagrams as shown in Figure 6. 
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Figure 6: Screenshot of UGADraw – ChartEditor for Diagrams 

Comparative Evaluation 

The UGADraw system was evaluated with some other existing applications such as 
Ms Paint, CorelDraw, PowerDraw, among others to assess its quality using 
summative type of evaluation. The evaluation paradigm adopted for the assessments 
include ‘Quick and dirty’ and Predictive evaluation. ‘Quick and Dirty’ was used with 
some intended users such as teachers whereas predictive paradigm was used with 
some Computer Science students. Several usability goals were considered during the 
evaluation. 

The Table below shows the summary of the comparative evaluation 

Usability 

Goals 

Related Tools 

Ms Paint CorelDraw PowerDraw UGADraw  

Effectiveness *** *** *** *** 

Efficiency *** *** *** *** 

Safety *** *** *** *** 

Utility ** ** ** *** 
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Learnability ** * * *** 

Memorability *** ** ** *** 

*** Strongly supported; ** Averagely supported; * Least supported 

Table 1: Comparative Evaluation   

Conclusion 

This paper discussed a teaching and learning application called UGADraw. It is a non 
distributed, offline software application that can be used by teachers, learners, 
instructors, among others. Major features of UGADraw include the provision of 
painting operations and tools in a local context to suit Ugandan educational needs, 
provision of an interface that can be used in a classroom environment as a visual aid 
by allowing free hand writing as well as sketching capability that allows work to be 
saved for future reference, and also provision of an interface that can be customised 
by the users to plot graphs, charts as well as diagrams such as data flow diagrams. 
Some applications of UGADraw include: classroom environment where it is used as a 
visual aid, and design of pictures for presentation purposes using applications such as 
Microsoft PowerPoint. UGADraw could also enhance electronic (e-) learning. 
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